(追記あり)【ハマった】Windows 10 May 2019 Update の自動更新の適用後にネットワーク不具合に遭遇した件【なんとか解決】

kimihikoです。

先日の記事でWindows 10 May 2019 Update(1903アップデート)に
無事アップデートしたと書きました。

諦めていた症状も治って一件落着~
…と思っていたのも束の間、
ドツボにハマっていたことが判明。

その一部始終です(笑)

ネットにつながらない

Windows 10 May 2019 Update後に
スリープから復帰したら
インターネット接続が切断されてしまっていることに気が付いた。

スリープが原因で一時的にWi-Fiが切れたのかなと思ったんですが、
スリープから復帰したら、いつもは自動的に接続を復帰していた。

今までこんなことは一度も無かった。

で、Wi-Fiの接続先一覧をみたら、
なぜか今まで使っていたWi-Fiの接続先が見当たらない。

「あれ?」

でも、たぶん今回の大型アップデートの影響だろうな、
という意識があって、そこまで焦りはなかった。

PCを再起動したり、ルーターを再起動したりすれば
接続先が見えるようになるだろうなぁと思ったんですね。

大型アップデートのあとなんで、
それくらいはあり得るだろうなって。

でも再起動しても、切断されたままでした。

接続先一覧を確認しても、やっぱり
これまで使っていた接続先がない。

「うーん…。」

ちなみに、手持ちのiPhoneだと
正常にWi-fiに接続してネットサーフィンもできてました。
なので回線自体がおかしいっていうことはなさそうで。

「もしかしてアップデートで設定が消えた?」

それならもう一度設定すれば見えるようになるはず。

うちはバッファロー製品なので
AOSSボタンを押して接続先が出てくるかなと。
さっそく、やってみました。

AOSSについてはこちらを参考↓

で、しばらくして接続先を検出したらしく、、、
アイコンもWi-Fiマークに変化。

試しにウェブページを開いてみたら
ページも見えたんでこれで、治ったぽい?

でも、なにか不安定

テストで、しばらくいくつかページをみたら
またすぐに接続が切れたようで、ページが見れなくなった。

再度、Wi-Fiの接続先一覧を見に行ったら
また接続先が無いっぽい。

「うう。。 さっきと同じ。」

何か根本的に治っていない感じがしました。

とりあえず、つながらないと不便で仕方がないので
有線LANを接続して、ネットに接続することに。

カチッと有線LANを接続したら、
タスクトレイのWi-Fiアイコンが有線LANのアイコンに代わって
とりあえず、ネットには接続できたのですが…。

なんとな~くいつもと雰囲気が違う気がしました。

OSの全体的な挙動が、何とは言えないのですが
なにかいつもと違う気がする。

で、テストでいくつかのウェブページを
ブラウザで開いていると…

インターネットに接続できません…という文字が。

「あれ…?また??」

で、タスクトレイのアイコンを見ると、
一応、LANに接続しているアイコンにはなっている。

でもネットに接続できない。

あれあれあれ(´Д`)?

不安が大きくなってきましたよ。。

それでも接続をONにしたりOFFにしたり
ネットワーク設定をいじっていると、またつながる。

明らかに不安定…。

(。´・ω・)ん? これスピード大丈夫?

不安定ながら、つながってるとき、もしかして、
回線スピードがめちゃくちゃ遅くなっていないか?
と感覚的に思って、
スピードテストを試してみました。

そしたら…

ダウンロード:0.x Mbps
アップロード:… … …

非常に低速です、というリザルトメッセージも出ました。

おいおいおい。
うちは、光回線やで。
なんでこんなクソ遅いんや?

ベストエフォートとはいえ、
このタイミングで、一時的に何かが起こっているということも
たぶん、あり得ない。

これはおかしい。
何かが、おかしくなった。
ただごとじゃないぞ。と。

調べまくる

とりあえず、調べまくりました。

Windows10 1903 のアップデートで不具合にあったという情報を。

あるにはあった。件数もそれなりに。

ただ今回のようなケース、
アップデート後にネットワーク接続がおかしくなる、
といった情報は見当たらなかった。

ええ…。どしよ。

ネットにまともに接続できひんと
話にならへんで…。

で、めぼしい情報も無さそうだなぁーと思いつつ、
少し気になるページがあった。

2019年5月22日より提供が開始されたWindows10 v1903 May 2019 Updateは、公開当初からMicrosoftより多数の不具合がアナウンスされていました。Microsoftは2019年7月11日付けで不具合リストを更新し、不具合のいくつかが解決したことを発表しました。

…と、して、
[ Windows10 v1903 既知の不具合 ]
[ Windows10 v1903 解決した既知の不具合 ]
それぞれズラーと不具合が並んでいる。

で、気になったのが、解決した既知の不具合のほうの
以下の項目。

  • 外付けUSBメモリやSDメモリカードを接続しているとv1903へのアップデートに失敗する場合がある。 (この不具合が発生する場合、全ての外付けメディアを外すことでインストールが正常に行われる) [※]

(『※』は問題が解決されるまでv1903が配信はされなかった不具合)

外付けのUSBメモリ…

そういえば、うちのPC。
無線LANが内蔵していなく、
外付けでUSBスティックタイプの無線用ネットワークアダプタを
使っていたんだった。

本体の裏側のUSBポートに刺しっぱなしになっていて
もう意識から飛んでいた。

もしかすると、アップデート後、そのUSBスティックの
ドライバがOSに対応していないのではないか、と。

さっそくチェックするも、
ドライバは最新のものらしく、問題なかった。

一応、ルーター本体側のファームウェアも最新かなぁと思って
調べてみたんですが最新でした。

いやいや。

これ、もしかすると最新のOSバージョンに、
このUSBスティックのドライバがまだ対応していない系の
不具合とかだったりする?

そうだったとしたら、もう待つしかなくて、、。

とはいえこの状態では不便で仕方ないので、
待ってもいられないので、
どうしようもないなと思いました。

そして、ダウングレードを決意

有線、無線問わず、
ネットに安定して接続できないのは致命的。

というわけで、こんなことはかなり稀なのですが、
ダウングレードしました。
(ダウングレードの方法は書くのが面倒なので割愛しますが、難しくはないです。)

無事、以前のバージョンには戻りました。

その後、再びUSBスティックを刺して、
さっそく、タスクトレイのネットワークアイコンをみてみました。

Wi-Fiのつながっていない状態…。

接続先一覧を開くと…
接続先が、ありません。

なんだこれ、戻したのに接続不良なおってへんわ…。

ダウングレードして前の状態に戻したはずなのに…。

ええ…。

ネットワーク系は元に戻らんのか…。

でも引き続き、冷静に考えました。

そういえば、外付けUSBスティックの件…。

USBスティックを接続したまま1903アップデートをしたために、
不具合を引き起こしたんだと仮定したら…。

それだったら、今の
元のバージョンに戻した状態、かつ、USBスティックは抜いた状態で、
もう一度、1903にアップデートをすれば、
今度は不具合にならないのではないかと。

再び1903へアップデート

というわけで、再び1903へのアップデートをかけました。
今度はUSBスティックは外した状態で。

。。

。。。

前回のとおり時間はかかりましたが
無事アップデートは完了。

USBスティックは抜いた状態なので無線接続はつかえないので
まずは有線でネットにつながっているか確認しました。
さっきは有線も不安定だったので。

とりあえずネット接続はOKでした。

さらに回線のスピードテストを実施しました。

ダウンロード:80 Mbps
アップロード:90 Mbps

非常に高速です。という表示が出ました。

( ´ ▽ ` )ノやったー

それからUSBスティックを接続し、Wi-Fiを確認…
接続先は出なかったものの、
AOSSによる新規の接続先を設定して、
接続したところ、
今度はスピードも良好で、安定していました。

これで、本当に問題解決となりました。

おしまいに

今回のアップデートでは、
結果的に非常にハマってしまいました。。。

ハマった内容(起きた問題)とその原因は以下のとおりでした。

  • アップデート後、無線・有線ともにネット接続が不安定になる問題が発生。
  • 原因は、外付け機器をつけていたこと。

起きた問題の原因が、外付け機器としてUSBスティックタイプの
ネットワークアダプタをさしっぱにしていたこと、だったんですが
正直、これがOSのアップデートに影響するとは
想像していませんでした。

いや、今考えたら外付け機器なんやし、
普通に考えれば影響する可能性はありそう…
かもですが…

  • USBスティックを差し込んでいるUSBポートがPCディスプレイの背面で目から見えない位置にあること
  • 常時差し込みっぱなしにしている

ということで外付け機器を使っているという認識が
どこか遠くへ飛んでいたのがいけませんでしたね。。ヽ(´o`;


ただそのせいで今回そこそこ苦労した
ので
今後の教訓にしたいと思います(´・ω・`)

いじょう。

追記あり:2019/07/27

またまた無線の接続先が消えてしまう事象が発生…。

パソコンを起動したら、消えていました…。

で、細かいことは端折(はしょ)るんですが、
今回の対応でやったことは、以下ページの無線チャンネルの変更です。

なお、利用しているBUFFALO製品のWi-Fiルーターに関連する
「パソコン環境表示ツール」というツールの
以下ヘルプ表示をきっかけに、上記ページには、たどり着きました。

2019-07-27_09h17_36
▲ヘルプ

既に無線の接続の設定が済んでいるのに接続できない場合
無線親機の無線チャンネルの値を変更してください。詳しくは、無線親機に付属のマニュアル(または…

の項目がまさに今回の事象にマッチしているなということで。

で、マニュアルのとおり、無線親機の無線チャンネルの値を変更しましたよ。


▲動画マニュアル

マニュアルページの参照や、無線親機の無線チャンネルの変更は
手持ちのiPhoneで行いましたよ。

こういうとき、PCとスマホを持っていて、
両方とも同じWi-fi環境で使っていてよかったな
と感じますね。

で、変更完了後、
何もしなくても、しばらくしたらWi-Fiに勝手につながっていました。
解決したようですね。

無線チャンネルの変更の具体的な内容については、
前述の動画マニュアルの通りなんですが、
少しテキストでも書いておきます。

  1. 前提として、利用している無線LANルータには2つの帯域がある(2.4GHz帯域と5GHz帯域)ことを知る。
  2. それぞれの帯域には複数のチャンネルが存在している(2.4GHz帯域には、1Ch/2Ch/3Ch… 、5GHz帯域には、36Ch/40Ch/44Ch…という具合)
  3. 2.4GHz帯域と5GHz帯域で利用しているチャンネルを、できる限り離すようにした。

チャンネルについては今までは自動で割り当てる設定になっていました。

自動で割り当てられていたのは、2.4GHz帯域が4ch、
5GHz帯域は何チャンネルだったか忘れてしまったんですが…、
これを手動設定に切り替えました。

2.4GHz帯域は1Ch、5GHz帯域は48chという具合に
自動接続のときより、チャンネルが離れるようにしました。

1903アップデート以前はトラブルなくWi-Fiにつながっていたので、
1903アップデートに関連して何かしらチャンネルの距離が
無線ネットワーク接続に干渉するようになったのか…。

とはいえもう割とコレ系の不具合はお腹いっぱいなので、
これ以上、何も起こらないでくれよと
願うばかりでございます。起こらない自信はないけど ヽ(´o`;

補足

ダウングレードした時点でも、新規で接続先を設定してたら、
そこでも一応ネットワーク接続は戻ったのかもしれませんが…。

いずれにせよOSはアップデートしたかったので結果オーライとします。